Сканер штрих кода

image_pdfimage_print

Печать (Ctrl+P)
Сканер штрих кода – это устройство, которое считывает штриховой код и передает его значение в конфигурацию. Обычно сканеры штрих кода используются либо непосредственно в формах списка справочников для поиска элемента справочника по штриховому коду и позиционирования на найденном элементе, либо в документах при подборе элементов справочника в табличную часть.
Например,

  •  поиск номенклатуры в справочнике;
  •  подбор номенклатуры в документы товародвижения;
  •  заполнение поля “Серия” по считанному штриховому коду серии товара;
  •  поиск документа по штриховому коду.

Штриховые коды бывают одномерными и двухмерными различных форматов. Различные модели сканеров поддерживают определенные форматы штриховых кодов. Для каждого объекта предварительно следует указать формат используемого кода, что позволяет верифицировать полученные от сканера данные при обработке кода.
Работа с оборудованием на форме производится в три этапа:

 1 . Инициализация сканера штрих кода

Перед тем как начать использовать сканер его необходимо инициализировать. Делать это лучше всего при открытии формы.  В соответствующем событии определяем, какое именно оборудование будет использоваться, и пытаемся его подключить. В данном случае только сканер штрихкода:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
// ПодключаемоеОборудование
Если МенеджерОборудованияКлиент.ОбновитьРабочееМестоКлиента() Тогда
ОписаниеОшибки = “” ;
ПоддерживаемыеТипыВО = Новый Массив();
ПоддерживаемыеТипыВО.Добавить( “СканерШтрихкода” );
Если Не МенеджерОборудованияКлиент.ПодключитьОборудованиеПоТипу(УникальныйИдентификатор, ПоддерживаемыеТипыВО, ОписаниеОшибки) Тогда
ТекстСообщения = НСтр( “ru = ‘При подключении оборудования произошла ошибка:
|””%ОписаниеОшибки%””.'” );
ТекстСообщения = СтрЗаменить(ТекстСообщения, “%ОписаниеОшибки%” , ОписаниеОшибки);
ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
КонецЕсли;
КонецЕсли;
// Конец ПодключаемоеОборудование
КонецПроцедуры

2. Использование сканера штрих кода

Работа со сканером организована через событие оповещения формы. При возникновении события нужно определить, что его источником является
сканер и использовать полученные от него данные. В приведённом ниже примере полученный от сканера код применяется в процедуре
ОбработатьПолученныйШК():

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
// ПодключаемоеОборудование
Если Источник = “ПодключаемоеОборудование”
И ВводДоступен() Тогда
Если ИмяСобытия = “ScanData” Тогда
Если Параметр[ 1 ] = Неопределено Тогда
ТекКод = Параметр[ 0 ];
Иначе
ТекКод = Параметр[ 1 ][ 1 ];
КонецЕсли;
ОбработатьПолученныйШК(ТекКод);
КонецЕсли;
КонецЕсли;
// Конец ПодключаемоеОборудование
КонецПроцедуры

3. Отключение сканера штрих кода

При закрытии формы оборудование необходимо отключить:

&НаКлиенте
Процедура ПриЗакрытии()
// ПодключаемоеОборудование
ПоддерживаемыеТипыВО = Новый Массив();
ПоддерживаемыеТипыВО.Добавить( “СканерШтрихкода” );
МенеджерОборудованияКлиент.ОтключитьОборудованиеПоТипу(УникальныйИдентификатор, ПоддерживаемыеТипыВО);
// Конец ПодключаемоеОборудование
КонецПроцедуры

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *