Считыватель магнитных карт

Печать (Ctrl+P)
Считыватель магнитных карт – это устройство, которое считывает магнитный код с карты и передает его значение в конфигурацию. Карты с магнитным кодом обычно используются в качестве карт лояльности покупателей или служебных карт сотрудников. На магнитной карте обычно
используется две или три дорожки. Используемая часть кода ограничивается префиксом и постфиксом, которые предварительно вносятся в систему пользователем. Состав параметров настройки может изменяться в зависимости от драйвера.
Работа с оборудованием на форме, так же как и работа со сканером штрихкодов, производится в три этапа.

1. Подключение Считывателя магнитных карт

Перед тем как начать использовать считыватель его необходимо инициализировать. Делать это лучше всего при открытии формы. В соответствующем событии определяем, какое именно оборудование будет использоваться. Тут же пытаемся его подключить. В данном случае только считыватель магнитных карт:

&НаКлиенте
Процедура ПриОткрытии (Отказ )
// ПодключаемоеОборудование
Если МенеджерОборудованияКлиент .ОбновитьРабочееМестоКлиента () Тогда
ОписаниеОшибки = “” ;
ПоддерживаемыеТипыВО = Новый Массив ();
ПоддерживаемыеТипыВО .Добавить ( “СчитывательМагнитныхКарт” );
Если Не МенеджерОборудованияКлиент .ПодключитьОборудованиеПоТипу (УникальныйИдентификатор , ПоддерживаемыеТипыВО , ОписаниеОшибки ) Тогда
ТекстСообщения = НСтр ( “ru = ‘При подключении оборудования произошла ошибка:
|””%ОписаниеОшибки%””.'” );
ТекстСообщения = СтрЗаменить (ТекстСообщения , “%ОписаниеОшибки%” , ОписаниеОшибки );
ОбщегоНазначенияКлиентСервер .СообщитьПользователю (ТекстСообщения );
КонецЕсли;
КонецЕсли;
// Конец ПодключаемоеОборудование
КонецПроцедуры

Надо помнить, что таким образом на каждый экземпляр объекта открытой формы будет создаваться по экземпляру объекта оборудования.

Использование Считывателя магнитных карт

Работа со считывателем организована через событие оповещения формы. При возникновении события нужно определить, что его источником является считыватель и использовать полученные от него данные. В приведённом ниже примере полученный от считывателя код применяется в процедуре ОбработатьПолученныйМК():

&НаКлиенте
Процедура ОбработкаОповещения (ИмяСобытия , Параметр , Источник )
// ПодключаемоеОборудование
Если Источник = “ПодключаемоеОборудование”
И ВводДоступен () Тогда
Если ИмяСобытия = “TracksData” Тогда
ТекКод = Параметр [ 0 ];
ОбработатьПолученныйМК (ТекКод );
КонецЕсли;
КонецЕсли;
// Конец ПодключаемоеОборудование
КонецПроцедуры

Отключение  Считывателя магнитных карт

При закрытии формы оборудование необходимо отключить:

&НаКлиенте
Процедура ПриЗакрытии ()
// ПодключаемоеОборудование
ПоддерживаемыеТипыВО = Новый Массив ();
ПоддерживаемыеТипыВО .Добавить ( “СчитывательМагнитныхКарт” );
МенеджерОборудованияКлиент .ОтключитьОборудованиеПоТипу (УникальныйИдентификатор , ПоддерживаемыеТипыВО );
// Конец ПодключаемоеОборудование
КонецПроцедуры

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *