Терминал сбора данных

image_pdfimage_print
Печать (Ctrl+P)

Терминал сбора данных

Это мобильный компьютер с процессором и встроенной памятью, оснащенный сканером штрихкодов. Устройство предназначено для оперативного сбора информации о товарах, при формировании отгрузки товаров и для решения множества других учётных задач.
Данные считываются с помощью встроенного в терминал сканера штрихкодов, обрабатываются и сохраняются в памяти терминала, а затем
выгружаются в компьютер через USB-соединение, ИК-порт, Bluetooth или другой интерфейс передачи данных.
Поддерживается выгрузка в терминал данных о товаре и загрузка данных о товаре и его количестве для формирования документов.
Перед запуском процедуры выгрузки в конфигурации подготавливается массив данных определенного типа. Полученная таблица с помощью функции библиотеки подключаемого оборудования преобразуется в формат .xml и методом драйвера передается в терминал сбора данных.
Загрузка данных из терминала производится в обратном порядке: метод драйвера передает данные в формате .xml, которые преобразуются функцией
библиотеки в соответствующий данным тип. Полученный массив данных обрабатывается в модуле формы в соответствии с прикладной логикой.

Выгрузка данных из базы в терминал

Перед тем как запустить выгрузку необходимо подготовить входные данные в определённом формате. На вход процедуре выгрузки подаётся
идентификатор клиента (формы) и таблица данных. Таблица представляет собой массив, элементами которого являются структуры с определённым
набором ключей соответствующих типов:

  •  Штрихкод, строка
  •  Номенклатура, строка
  •  ЕдиницаИзмерения, строка
  •  ХарактеристикаНоменклатуры, строка
  •  СерияНоменклатуры, строка
  •  Качество, строка
  •  Цена, число
  •  Количество, число

Ниже приведён пример выгрузки данных в терминал из таблицы формы ТабличнаяЧасть:

&НаКлиенте
Процедура ВыгрузитьВТСД ()
ТаблицаТСД = Новый Массив ;
Для каждого текСтрока Из ТабличнаяЧасть Цикл
НоваяСтрока = Новый Структура ( “Штрихкод, Номенклатура, Количество”
,Строка (текСтрока .Штрихкод ), Строка (текСтрока .Номенклатура ), Число (текСтрока .Количество ));
ТаблицаТСД.Добавить (НоваяСтрока );
КонецЦикла;
МенеджерОборудованияКлиент.ВыгрузитьДанныеВТСД (УникальныйИдентификатор , ТаблицаТСД );
КонецПроцедуры

Загрузка данных в базу из терминала

Для загрузки необходимо вызвать соответствующую процедуру подсистемы. Таблица с данными будет возвращена в качестве второго параметра
процедуры. Таблица представляет собой массив, элементами которого являются структуры со следующими ключами:

  • Штрихкод, строка
  • Количество, число

Полученный результат надо обработать согласно задачам, стоящим перед разработчиком. Например, так;

&НаКлиенте
Процедура ЗагрузитьИзТСД ()
ТаблицаТСД = Неопределено;
МенеджерОборудованияКлиент.ЗагрузитьДанныеИзТСД (УникальныйИдентификатор , ТаблицаТСД );
Для каждого текСтрока Из ТаблицаТСД Цикл
НоваяСтрока = ТабличнаяЧасть .Добавить ();
НоваяСтрока.Штрихкод = текСтрока .Штрихкод ;
НоваяСтрока.Количество = текСтрока .Количество ;
КонецЦикла;
КонецПроцедуры

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *