Преобразование строки в дату.

Печать (Ctrl+P)

Работа со строками в БСП 3.0

Общий модуль СтроковыеФункцииКлиентСервер

  Дата  = СтроковыеФункцииКлиентСервер.СтрокаВДату(Значение );   

Преобразует исходную строку в дату.

Параметры:
Значение – Строка – строка, которую необходимо привести к дате.
Формат даты должен быть в виде “ДД.ММ.ГГГГ” или “ДД/ММ/ГГ” или “ДД-ММ-ГГ”

Например, “23.02.1980” или “23/02/80”.
Возвращаемое значение: Дата – полученная дата.

Функция СтрокаВДату(Знач Значение) Экспорт
 Значение = СтрЗаменить(Значение, " ", "");
 Значение = СокрЛП(СтрЗаменить(Значение, ".", ""));
 Значение = СокрЛП(СтрЗаменить(Значение, "/", "")); 
Значение = СокрЛП(СтрЗаменить(Значение, "-", "")); 
Значение = Сред(Значение, 5) + Сред(Значение, 3, 2) + Лев(Значение, 2);
 Если СтрДлина(Значение) = 6 Тогда 
    Год = СтрокаВЧисло(Лев(Значение, 2));
     Если Год = Неопределено Тогда
          Возврат Дата('0001.01.01');
     КонецЕсли; 
    Значение = ?(Год > 29, "19", "20") + Значение; 
КонецЕсли; 
ОписаниеТипа = Новый ОписаниеТипов("Дата"); 
Результат    = ОписаниеТипа.ПривестиЗначение(Значение);
 Возврат Результат;
 КонецФункции 

См. также

0

Автор публикации

не в сети 4 часа

master1c8

0
Комментарии: 14Публикации: 439Регистрация: 25-12-2016

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.