Дисплей покупателя

Печать (Ctrl+P)

Библиотека подключаемого оборудования, версия 1.0

Сканер штрихкода
Считыватель магнитных карт
Терминал сбора данных
Дисплей покупателя
Фискальный регистратор
Эквайринговый терминал
Электронные весы
Весы с печатью этикеток
ККМ офлайн

Дисплей покупателя представляет собой электронное табло, на котором, как правило, отображается информация о покупке (сумма чека, сумма сдачи, наименование товара и т. д.)

При использовании дисплея покупателя используются следующие команды:

  • Подключение устройства
  • Очистка экрана
  • Вывод текста
  • Отключение устройства

При выводе текста на дисплей покупателя в параметрах команды можно указать, в какой области экрана будет отображаться данный показатель.

Начало работы

Перед тем как начать использовать дисплей покупателя – его необходимо подключить. Делается это следующим образом:

&НаКлиенте
 Процедура ПриОткрытии (Отказ )...
  ПоддерживаемыеТипыВО =  Новый Массив ();
  ПоддерживаемыеТипыВО.Добавить ( "ДисплейПокупателя" );
 Если  Не МенеджерОборудованияКлиент .ПодключитьОборудованиеПоТипу (УникальныйИдентификатор , ПоддерживаемыеТипыВО , ОписаниеОшибки )  Тогда
    ТекстСообщения = НСтр ( "ru = 'При подключении оборудования произошла ошибка:
                |""%ОписаниеОшибки%"".'" );
    ТекстСообщения = СтрЗаменить (ТекстСообщения ,  "%ОписаниеОшибки%" , ОписаниеОшибки );
    ОбщегоНазначенияКлиентСервер.СообщитьПользователю (ТекстСообщения );
 КонецЕсли;...
 КонецПроцедуры

Использование дисплея покупателя

При работе с дисплеем покупателя на его экран можно: выводить текст, очищать экран, задавать область вывода текста.

Очистка экрана

Перед выводом текста экран дисплея необходимо очистить.

ВходныеПараметры =  Новый Массив ();
ВыходныеПараметры =  Неопределено;
МенеджерОборудованияКлиент.ВыполнитьКоманду (ИдентификаторУстройстваДП ,
 "ClearText" ,
ВходныеПараметры,
ВыходныеПараметры);

Вывод текста

Вывод текста на экран дисплея производится следующим образом:

ВходныеПараметры =  Новый Массив ();
ВыходныеПараметры =  Неопределено;
ВходныеПараметры.Добавить (ТекстДП );      // Текст
МенеджерОборудованияКлиент.ВыполнитьКоманду (ИдентификаторУстройстваДП ,
 "DisplayText" ,
ВходныеПараметры,
ВыходныеПараметры);

Окончание работы

При завершении работы с дисплеем покупателя, его необходимо отключить:

&НаКлиенте
 Процедура ПриЗакрытии ()...
  ПоддерживаемыеТипыВО =  Новый Массив ();
  ПоддерживаемыеТипыВО.Добавить ( "ДисплейПокупателя" );
  МенеджерОборудованияКлиент.ОтключитьОборудованиеПоТипу (УникальныйИдентификатор , ПоддерживаемыеТипыВО );...
 КонецПроцедуры
0

Автор публикации

не в сети 4 недели

master1c8

0
Комментарии: 13Публикации: 426Регистрация: 25-12-2016

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.