Подсистема «Свойства» БСП

Печать (Ctrl+P)

По материалам документации БСП 2.4

Данная статья написана по материалам документации библиотеки стандартных подсистем 2.4.

Подсистема «Свойства» позволяет создавать и редактировать в режиме 1С:Предприятие дополнительные свойства произвольных объектов конфигурации (не внося изменения в саму конфигурацию).
Для того чтобы использовать дополнительные свойства, необходимо включить флажок Дополнительные реквизиты и сведения в разделе Администрирование – Общие настройки.

Дополнительные свойства объектов могут быть двух видов:

  • дополнительные реквизиты – это свойства, которые хранятся в самом объекте (в специализированной табличной части). Дополнительные реквизиты являются неотъемлемой частью объекта, вводятся при его редактировании и доступны для редактирования тем же пользователям, которым доступен и сам объект со свойствами. Например, реквизиты вес, размеры, цвет справочника товары.
  • дополнительные сведения – не являются неотъемлемыми свойствами объекта. Они, как правило, доступны для редактирования тем пользователям, которые не имеют доступа к самому объекту. При внедрении подсистемы совместно с подсистемой «Управление доступом» имеется возможность ограничивать доступ пользователей к отдельным дополнительным сведениям. Например, дата ближайшей поставки товара.

Входящие объекты в подсистему “свойства”

Общие модули

  • УправлениеСвойствами
  • УправлениеСвойствамиКлиент
  • УправлениеСвойствамиПереопределяемый
  • УправлениеСвойствамиСлужебный

Роли

  • Добавление и изменение дополнительных реквизитов и сведений
  • Изменение дополнительных сведений
  • Чтение дополнительных сведений

Подписки на событие

  • СвойстваПередУдалениемСсылочногоОбъекта – Обработчик события выполняет поиск ссылок на удаляемые объекты в таблице зависимостей дополнительных реквизитов

Функциональные опции ( Константы)

  • ИспользоватьДополнительныеРеквизитыИСсведения
  • ИспользоватьОбщиеДополнительныеЗначения
  • ИспользоватьОбщиеДополнительныеРеквизитыИСведения

Определяемые типы данных

  • ВладелецДополнительныхСведений

Общие формы

  • РедактированиеГиперссылки
  • РедактированиеДополнительныхСведений – Предназначен для просмотра и ввода значений дополнительных сведений. Ввод значений дополнительных сведений, как правило, осуществляется в отдельном окне, в отличие от дополнительных реквизитов. Открывается с помощью кнопки Дополнительные сведения из окон объектов программы, для которых были настроены дополнительные сведения..В списке выводится Наименование и Значение дополнительного сведения.

Общие команды ( Командная панель)

  • ДополнительныеСведенияКоманднаяПанель

Справочники

  • ЗначенияСвойствОбъектов ( Дополнительные значения )-В списке задаются значения дополнительных реквизитов и сведений.
  • ЗначенияСвойствОбъектовИерархия (Дополнительные значения иерархия)- В списке можно использовать иерархию значений. Элементы в таком списке имеют одинаковые свойства, но могут иметь подчиненные элементы. При этом иерархия может быть довольно сложной. Можно выбрать любой элемент иерархии, в отличие от сгруппированного списка дополнительных значений, в котором наименования групп выбрать в качестве значения невозможно.
  • НаборыДополнительныхРеквизитовИСведений – Предназначен для настройки наборов дополнительных свойств. Можно настроить наборы дополнительных свойств для определенных объектов программы.

Планы видов характеристик

  • ДополнительныеРеквизитыИСведения

Регистры сведений

  • ДополнительныеСведения – Для некоторых объектов конфигурации можно указать дополнительные сведения, состав и тип которых настраивается администратором. В регистре хранятся свойства и значений этих объектов

Программный интерфейс подсистемы “Свойства”

Программный интерфейс БСП включает в себя все экспортные процедуры и функции, которые размещены в областях кода ПрограммныйИнтерфейс.

Для удобства поиска и изучения программный интерфейс сгруппирован по подсистемам и разделен на две основные категории:

Интерфейс – экспортные процедуры и функции, которые предназначены для вызова из прикладного кода;

Переопределение – экспортные процедуры переопределяемых модулей, содержимое которых может или должно быть изменено в конфигурации-потребителе. С их помощью решаются задачи изменения поведения библиотечной функциональности, ее параметризации спецификой конфигурации-потребителя, а также для подключения библиотечной функциональности к объектам конфигурации-потребителя. Они не предназначены для вызова из прикладного кода.


Экспортные процедуры и функции, которые предназначены для вызова из прикладного кода

  1. ВыполнитьКоманду – Обработчик команд с форм, к которым подключены дополнительные свойства.
  2. ЗаписатьСвойстваУОбъекта – Записывает дополнительные реквизиты и сведения владельцу свойств. Изменения происходят в транзакции
  3. ЗаполнитьДополнительныеРеквизитыВФорме – Создает/пересоздает дополнительные реквизиты и элементы в форме владельца свойств.
  4. ЗначениеСвойства – Возвращает значение дополнительного свойства объекта.
  5. ЗначенияСвойств – Возвращает значения дополнительных свойств объектов.
  6. ИспользоватьДопРеквизиты – Проверяет, используются ли дополнительные реквизиты с объектом.
  7. ИспользоватьДопСведения – роверяет, используются ли дополнительные сведения объектом.
  8. ОбновитьЗависимостиДополнительныхРеквизитов
    Обновляет видимость, доступность и обязательность заполнения дополнительных реквизитов
  9. ОбновитьНаименованияНаборовИСвойств – Обновляет наименования предопределенных наборов свойств, если они отличаются от текущих представлений соответствующих им объектам метаданных со свойствами. . Обновляет наименования не общих свойств, если у них уточнение отличается от наименования их набора. Устанавливает пометку удаления у не общих свойств, если установлена пометка удаления их наборов.
  10. ОбновитьЭлементыДополнительныхРеквизитов – Обновляет отображаемые данные на форме объекта со свойствами.
  11. ОбрабатыватьОповещения – Определяет, что указанное событие – это событие об изменении набора свойств.
  12. ОбработкаПроверкиЗаполнения – Проверяет заполненность реквизитов обязательных для заполнения.
  13. ПередЗаписьюВидаОбъекта – Обновляет наборы дополнительных реквизитов и сведений для вида объектов со свойствами. Используется при записи элементов справочников, которые являются видами объектов со свойствами. Например, если есть справочник Номенклатура к которому применяется подсистема Свойства, для него создан справочник ВидыНоменклатуры, то при записи элемента ВидНоменклатуры необходимо вызывать эту процедуру
  14. ПередЗаписьюНаСервере – Заполняет объект из реквизитов, созданных в форме. Вызывается из обработчика ПередЗаписьюНаСервере формы объекта со свойствами.
  15. ПеренестиЗначенияИзРеквизитовФормыВОбъект – Переносит значения свойств из реквизитов формы в табличную часть объекта
  16. ПослеЗагрузкиДополнительныхРеквизитов – Проверяет наличие зависимых дополнительных реквизитов на форме и, при необходимости, подключает обработчик ожидания проверки зависимостей реквизитов.
  17. ПриСозданииНаСервере – Создает основные реквизиты и поля формы, необходимые для работы. Заполняет дополнительные реквизиты, если используются. Вызывается из обработчика ПриСозданииНаСервере формы объекта со свойствами.
  18. ПриЧтенииНаСервере – Заполняет объект из реквизитов, созданных в форме. Вызывается из обработчика ПередЗаписьюНаСервере формы объекта со свойствами.
  19. ПроверитьСвойствоУОбъекта — Проверяет, есть ли у объекта свойство.
  20. СвойстваОбъекта – Возвращает дополнительные реквизиты и сведения у указанного объекта.
  21. СтруктураПараметровНабораСвойств – Получает структуру параметров для набора свойств.
  22. УдалитьСтарыеРеквизитыИЭлементы – Удаляет старые реквизиты и элементы формы.
  23. УстановитьПараметрыНабораСвойств – Устанавливает параметры набора свойств.

Экспортные процедуры переопределяемой модули

  1. ЗаполнитьНаборыСвойствОбъекта – Заполняет наборы свойств объекта. Обычно требуется, если наборов более одного.

Порядок настройки объектов с дополнительными реквизитами

1. Создать табличную часть ДополнительныеРеквизиты с реквизитами:

ИмяТипПодсказка
СвойствоПланВидовХарактеристикСсылка. Дополнительные РеквизитыИ СведенияДополнительный реквизит
ЗначениеХарактеристика. Дополнительные Реквизиты И СведенияЗначение дополнительного реквизита
ТекстоваяСтрокаСтрока неограниченной длиныПолный текст строкового дополнительного реквизита

2. Реквизиту Значение в свойстве Связи параметров выбора установить связь: Отбор.Владелец(ДополнительныеРеквизиты.Свойство).

3 . В форме объекта рекомендуется создать специальную группу полей или страницу с наименованием ГруппаДополнительныеРеквизиты для размещения элементов управления, редактирующих свойства объекта.

4. В обработчике события ПриСозданииНаСервере формы объекта необходимо выполнить вызов:

// СтандартныеПодсистемы.Свойства 
ДополнительныеПараметры = Новый Структура;
ДополнительныеПараметры.Вставить("ИмяЭлементаДляРазмещения", "ГруппаДополнительныеРеквизиты");
УправлениеСвойствами.ПриСозданииНаСервере(ЭтотОбъект, ДополнительныеПараметры);
// Конец СтандартныеПодсистемы.Свойства

где ГруппаДополнительныеРеквизиты – имя группы формы, созданной на шаге 3, в которой будут располагаться поля формы, предназначенные для редактирования дополнительных реквизитов. Если этот параметр не указывать, то элементы управления для редактирования свойств будут размещаться в нижней части формы.

5. В некоторых случаях возникает необходимость размещать дополнительные реквизиты в разных местах формы, например, когда в форме с несколькими страницами на каждой из них выводится свой набор свойств. В таком случае в параметр ИмяЭлементаДляРазмещения необходимо передать список значений, где значение – ссылка на предопределенный набор свойств, а представление – имя группы формы, в которую выводить его реквизиты. Например, в форме объекта справочника _ДемоКонтрагенты:

Вот фрагмент программного кода обработчика события ПриСозданииНаСервере в этой форме объекта :

СправочникНаборы = Справочники.НаборыДополнительныхРеквизитовИСведений; 
ГруппыДляРазмещения = Новый СписокЗначений;
ГруппыДляРазмещения.Добавить(СправочникНаборы.СправочникДемоКонтрагентыОсновное, Элементы.ГруппаОсновное.Имя);
ГруппыДляРазмещения.Добавить("ВсеОстальные", Элементы.ГруппаПрочее.Имя);
ДополнительныеПараметры = Новый Структура;
ДополнительныеПараметры.Вставить("ИмяЭлементаДляРазмещения", ГруппыДляРазмещения);
УправлениеСвойствами.ПриСозданииНаСервере(ЭтотОбъект,ДополнительныеПараметры);

Значение ВсеОстальные в группах для размещения указывает, куда выводить дополнительные реквизиты тех наборов, которые не перечислены в данном списке.

При использования формы для работы с разными объектами следует передать параметр ПроизвольныйОбъект со значением Истина и в дальнейшем вызывать процедуру ОбновитьЭлементыДополнительныхРеквизитов для разных объектов.

6. В модуле формы каждого объекта со свойствами необходимо добавить процедуру:

#Область ОбработчикиКомандФормы 
...
// СтандартныеПодсистемы.Свойства
&НаКлиенте
Процедура Подключаемый_СвойстваВыполнитьКоманду(ЭлементИлиКоманда, НавигационнаяСсылка = Неопределено, СтандартнаяОбработка = Неопределено) УправлениеСвойствамиКлиент.ВыполнитьКоманду(ЭтотОбъект, ЭлементИлиКоманда, СтандартнаяОбработка);
КонецПроцедуры
// Конец СтандартныеПодсистемы.Свойства #КонецОбласти

7. В обработчике события ОбработкаОповещения добавить код:

// СтандартныеПодсистемы.Свойства 
Если УправлениеСвойствамиКлиент.ОбрабатыватьОповещения(ЭтотОбъект, ИмяСобытия, Параметр) Тогда
ОбновитьЭлементыДополнительныхРеквизитов(); УправлениеСвойствамиКлиент.ПослеЗагрузкиДополнительныхРеквизитов(ЭтотОбъект);
КонецЕсли;
// Конец СтандартныеПодсистемы.Свойства

8. В обработчике события ПриОткрытии добавить код:

 // СтандартныеПодсистемы.Свойства     УправлениеСвойствамиКлиент.ПослеЗагрузкиДополнительныхРеквизитов(ЭтотОбъект); // Конец СтандартныеПодсистемы.Свойства 

9. Добавить вспомогательные процедуры:

#Область СлужебныеПроцедурыИФункции 
// СтандартныеПодсистемы.Свойства
&НаСервере Процедура ОбновитьЭлементыДополнительныхРеквизитов() УправлениеСвойствами.ОбновитьЭлементыДополнительныхРеквизитов(ЭтотОбъект); КонецПроцедуры
&НаКлиенте
Процедура ОбновитьЗависимостиДополнительныхРеквизитов() УправлениеСвойствамиКлиент.ОбновитьЗависимостиДополнительныхРеквизитов(ЭтотОбъект);
КонецПроцедуры
&НаКлиенте
Процедура Подключаемый_ПриИзмененииДополнительногоРеквизита(Элемент) УправлениеСвойствамиКлиент.ОбновитьЗависимостиДополнительныхРеквизитов(ЭтотОбъект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.Свойства
11111111111111111111 #КонецОбласти

10. В обработчике события ПриЧтенииНаСервере добавить код:

// СтандартныеПодсистемы.Свойства УправлениеСвойствами.ПриЧтенииНаСервере(ЭтотОбъект, ТекущийОбъект); 
// Конец СтандартныеПодсистемы.Свойства

11. В обработчике события  ОбработкаПроверкиЗаполненияНаСервере добавить код:

// СтандартныеПодсистемы.Свойства УправлениеСвойствами.ОбработкаПроверкиЗаполнения(ЭтотОбъект, Отказ, ПроверяемыеРеквизиты); // Конец СтандартныеПодсистемы.Свойства

12. В обработчике события ПередЗаписьюНаСервере добавить код:

// СтандартныеПодсистемы.Свойства УправлениеСвойствами.ПередЗаписьюНаСервере(ЭтотОбъект, ТекущийОбъект);
// Конец СтандартныеПодсистемы.Свойства

Порядок настройки отложенной инициализации дополнительных реквизитов

Дополнительные реквизиты, расположенные на отдельной странице (закладке) формы, необходимо загружать отложенно. Это позволит существенно ускорить открытие форм.

Важно! При отложенной инициализации будет невозможно выполнить перемещение дополнительных реквизитов при помощи команды Изменить форму из группы, в которой они расположены.

1. В обработчике события ПриСозданииНаСервере формы объекта, в блоке кода:

// СтандартныеПодсистемы.Свойства 
ДополнительныеПараметры = Новый Структура; ДополнительныеПараметры.Вставить("ИмяЭлементаДляРазмещения", "ГруппаДополнительныеРеквизиты"); УправлениеСвойствами.ПриСозданииНаСервере(ЭтотОбъект, ДополнительныеПараметры);
// Конец СтандартныеПодсистемы.Свойства

дополнить структуру новым параметром ОтложеннаяИнициализация:

ДополнительныеПараметры.Вставить("ОтложеннаяИнициализация", Истина);

2. В обработчике ПриСменеСтраницы группы страниц, в которой выводятся дополнительные реквизиты, добавить код:

// СтандартныеПодсистемы.Свойства 
Если ЭтотОбъект.ПараметрыСвойств.Свойство(ТекущаяСтраница.Имя) И Не ЭтотОбъект.ПараметрыСвойств.ВыполненаОтложеннаяИнициализация Тогда СвойстваВыполнитьОтложеннуюИнициализацию(); УправлениеСвойствамиКлиент.ПослеЗагрузкиДополнительныхРеквизитов(ЭтотОбъект);
КонецЕсли;
// Конец СтандартныеПодсистемы.Свойства

3. Добавить вспомогательную процедуру:

#Область СлужебныеПроцедурыИФункции
&НаСервере
Процедура СвойстваВыполнитьОтложеннуюИнициализацию() УправлениеСвойствами.ЗаполнитьДополнительныеРеквизитыВФорме(ЭтотОбъект); КонецПроцедуры
#КонецОбласти

Порядок настройки объектов с дополнительными сведениями

  1. Достаточно перечислить типы объектов с дополнительными сведениями в составе определяемого типа ВладелецДополнительныхСведений. Поддерживаемые типы объектов – документы, справочники, планы видов характеристик, планы счетов, планы видов расчета, бизнес-процессы и задачи.

Порядок настройки динамических списков

Для возможности отображения дополнительных реквизитов и сведений в формах списков объектов со свойствами необходимо добавить поле Ссылка из запроса динамического списка в таблицу формы, связанную с этим динамическим списком. При этом добавленное поле Ссылка следует по умолчанию скрыть от пользователей, сняв флаг Видимость в свойстве Пользовательская видимость.

Порядок настройки наборов свойств объектов

В большинстве случаев достаточно одного набора свойств для объекта метаданных, например, у всех элементов справочника товаров должны быть такие свойства, как вес, размеры, цвет и т.д. Для этого необходимо:

1. В справочнике НаборыДополнительныхРеквизитовИСведений создать предопределенный элемент с именем Справочник_<ИмяОбъекта>, если объект – справочник, например:
 Справочник__ДемоКонтрагенты, или Документ_<ИмяОбъекта>, если объект – документ, например : Документ_АвансовыйОтчет. Наименование элемента при этом заполнять не требуется (оно будет заполнено автоматически на основании представления списка того объекта, к которому относится данный элемент).

2. Добавить в обработчике обновления информационной базы вызов процедуры УстановитьПараметрыНабораСвойствобщего модуля УправлениеСвойствами для заполнения настроек добавленного набора свойств.

3. В обработчике ПередЗаписью модуля объекта этого справочника выполнить вызов УправлениеСвойствами.ПриЗаписиВидаОбъекта и передать туда в качестве параметров записываемый объект и имя набора свойств, например:

// СтандартныеПодсистемы.Свойства УправлениеСвойствами.ПередЗаписьюВидаОбъекта(ЭтотОбъект, "Справочник_ДемоНоменклатура");
// Конец СтандартныеПодсистемы.Свойства

Если справочник группирует объекты более чем одного типа, следует сделать два или более вызова, указав имена используемых реквизитов, например:

// СтандартныеПодсистемы.Свойства УправлениеСвойствами.ПередЗаписьюВидаОбъекта(ЭтотОбъект, "Справочник_ДемоОшибки","НаборСвойствОшибок"); УправлениеСвойствами.ПередЗаписьюВидаОбъекта(ЭтотОбъект, "Справочник_ДемоЗадачи","НаборСвойствЗадач");
// Конец СтандартныеПодсистемы.Свойства

4. В объекте – владельце свойств создать реквизит, значения которого определяют применение того или иного набора свойств для конкретного экземпляра объекта. Для справочника _ДемоНоменклатура это реквизит ВидНоменклатуры типа  СправочникСсылка._ДемоВидыНоменклатуры.

5. В модуле формы объекта реализовать обработчик ПриИзменении для элемента формы, редактирующего этот реквизит. Для справочника _ДемоНоменклатура это обработчик:

&НаКлиенте
Процедура ВидНоменклатурыПриИзменении(Элемент) ОбновитьЭлементыДополнительныхРеквизитов();
КонецПроцедуры

6. В процедуре ЗаполнитьНаборыСвойствОбъекта общего модуля УправлениеСвойствамиПереопределяемый вставить условие, заполняющее набор свойств для конкретного объекта. Например, для _ДемоНоменклатура это следующее условие:

Процедура ЗаполнитьНаборыСвойствОбъекта(Объект, ТипСсылки, НаборыСвойств, СтандартнаяОбработка, КлючНазначения) Экспорт 
Если ТипСсылки = Тип("СправочникСсылка._ДемоНоменклатура") Тогда ЗаполнитьНаборСвойствПоВидуНоменклатуры( Объект, ТипСсылки, НаборыСвойств);
КонецЕсли;
КонецПроцедуры
Процедура ЗаполнитьНаборСвойствПоВидуНоменклатуры(Номенклатура, ТипСсылки, НаборыСвойств)
Если ТипЗнч(Номенклатура) = ТипСсылки Тогда Номенклатура = ОбщегоНазначения.ЗначенияРеквизитовОбъекта( Номенклатура, "ЭтоГруппа, ВидНоменклатуры");
КонецЕсли;
Если Номенклатура.ЭтоГруппа = Ложь Тогда
Строка = НаборыСвойств.Добавить();
Строка.Набор = ОбщегоНазначения.ЗначениеРеквизитаОбъекта( Номенклатура.ВидНоменклатуры, "НаборСвойств");
КонецЕсли;
КонецПроцедуры

Если справочник группирует объекты более чем одного типа, следует вписать в условие несколько типов, например:

  Если ТипСсылки = Тип("СправочникСсылка._ДемоОшибки") ИЛИ ТипСсылки = Тип("СправочникСсылка._ДемоЗадачи") Тогда         ЗаполнитьНаборСвойствПоПроекту( Объект, ТипСсылки, НаборыСвойств);     КонецЕсли;

7. В справочнике НаборыДополнительныхРеквизитовИСведений создать предопределенную группу с именем Справочник_<ИмяОбъекта>, если объект – справочник: Документ_<ИмяОбъекта>, если объект – документ, и т. д. Например, для справочника _ДемоНоменклатура создана предопределенная группа Справочник__ДемоНоменклатура. Наименование элемента при этом заполнять не требуется (оно будет заполнено автоматически на основании представления списка того объекта, к которому относится данный элемент).

8. Добавить в обработчике обновления информационной базы вызов процедуры УстановитьПараметрыНабораСвойствобщего модуля УправлениеСвойствами для заполнения настроек добавленного набора свойств.

Порядок настройки объектов с несколькими объединяющимися наборами свойств

Наборы свойств при этом должны объединяться в зависимости от тех или иных реквизитов объекта. Например, в справочнике партнеры могут быть введены клиенты, поставщики, конкуренты и партнеров, с которыми связывают прочие отношения. При этом один и тот же партнер может одновременно быть и тем, и другим, и третьим, а его дополнительные свойства должны динамически выводиться в зависимости от того, каких он типов. 

В демонстрационной конфигурации этот вариант показан на справочнике _ДемоПартнеры. В нем введены реквизиты КлиентПоставщикКонкурентПрочиеОтношения типа Булево, которые и определяют применение одного или сразу нескольких наборов свойств.

При этом подходе справочник имеет один предопределенный набор свойств для всех экземпляров объектов, а также несколько предопределенных наборов свойств, которые могут применяться к экземплярам данного объекта по тем или иным условиям.

Последовательность настройки такого объекта:

1. Принять решение по поводу наборов свойств объекта. Например, для справочника _ДемоПартнеры демонстрационной конфигурации это четыре набора свойств: реквизиты КлиентПоставщикКонкурентПрочиеОтношения.

2. Выявить реквизиты объекта, значения которых определяют применение того или иного набора свойств для конкретного экземпляра объекта. Например, для справочника _ДемоПартнеры демонстрационной конфигурации это реквизиты Клиент,ПоставщикКонкурентПрочиеОтношения.

3. В справочнике НаборыДополнительныхРеквизитовИСведений создать предопределенную группу с именем Справочник_<ИмяОбъекта>, если объект – справочник; Документ_<ИмяОбъекта>, если объект – документ, и т. д. Например, Справочник_Контрагенты. Наименование элемента при этом заполнять не требуется (оно будет заполнено автоматически на основании представления списка того объекта, к которому относится данный элемент).

4. В этой предопределенной группе для каждого из наборов свойств создать предопределенный элемент с именами Справочник_<ИмяОбъекта>_<ИмяНабораСвойств>, например Справочник_Партнеры_Клиенты. Прим этом наименование элемента следует задавать краткое, например Клиенты; оно не должно содержать имя и тип объекта метаданных.

5. В этой предопределенной группе создать предопределенный элемент с именем Справочник_<ИмяОбъекта>_Общие и наименованием Общие, который будет содержать общие свойства для всех объектов.

6. В общем модуле УправлениеСвойствамиПереопределяемый в процедуре ЗаполнитьНаборыСвойствОбъекта следует вписать условие для данного типа объектов. Для справочника _ДемоПартнеры это код вида:

Процедура ЗаполнитьНаборыСвойствОбъекта(Объект, ТипСсылки, НаборыСвойств, СтандартнаяОбработка) Экспорт
Если ТипСсылки = Тип("СправочникСсылка._ДемоПартнеры") Тогда ЗаполнитьНаборыСвойствПартнера(Объект, ТипСсылки, НаборыСвойств); КонецЕсли;
КонецПроцедуры
Процедура ЗаполнитьНаборыСвойствПартнера(Партнер, ТипСсылки, НаборыСвойств) Если ТипЗнч(Партнер) = ТипСсылки Тогда
Объект = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(Партнер, "Клиент, Конкурент, Поставщик, ПрочиеОтношения, ЭтоГруппа");
Иначе
Объект = Партнер;
КонецЕсли;
Если Объект.ЭтоГруппа = Ложь Тогда
Строка = НаборыСвойств.Добавить();
Строка.Набор = Справочники.НаборыДополнительныхРеквизитовИСведений.Справочник_Партнеры_Общие;
Строка.Отображение = ОтображениеОбычнойГруппы.Линия; Строка.ОтображатьЗаголовок = Истина;
Строка.Заголовок = НСтр("ru = 'Для всех партнеров'");
Если Объект.Клиент Тогда
Строка = НаборыСвойств.Добавить();
Строка.Набор = Справочники.НаборыДополнительныхРеквизитовИСведений.Справочник_Партнеры_Клиенты;
Строка.Отображение = ОтображениеОбычнойГруппы.Линия; Строка.ОтображатьЗаголовок = Истина;
Строка.Заголовок = НСтр("ru = 'Для клиентов'");
КонецЕсли;
КонецПроцедуры

В приведенном примере проверяются значения реквизитов справочника КлиентПоставщикКонкурентПрочиеОтношения и наборы свойств добавляются в таблицу НаборыСвойств. В поле Набор устанавливается ссылка на набор свойств, а в остальные поля могут быть установлены значения оформления набора в форме.

7. В форме объекта необходимо реализовать обработчики ПриИзменении для тех реквизитов, которые определят состав наборов свойств, применяемых для данного экземпляра объекта. Например, для формы справочника _ДемоПартнеры это обработчики вида:

&НаКлиенте
Процедура КлиентПриИзменении(Элемент)
// СтандартныеПодсистемы.Свойства ОбновитьЭлементыДополнительныхРеквизитов();
// Конец СтандартныеПодсистемы.Свойства
КонецПроцедуры
0

Автор публикации

не в сети 2 недели

master1c8

0
Комментарии: 11Публикации: 426Регистрация: 25-12-2016

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.