Является ли строка уникальным идентификатором

Печать (Ctrl+P)

Работа со строками в БСП 3.0

Общий модуль СтроковыеФункцииКлиентСервер

Для проверки является ли строка уникальным идентификатором предназначена следующая функция в библтотеке стандартных подсистем .

СтроковыеФункцииКлиентСервер.ЭтоУникальныйИдентификатор(СтрокаИдентификатора)

В качестве уникального идентификатора предполагается строка вида
“XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX”, где X = [0..9,a..f].
Параметры:
СтрокаИдентификатора – Строка – проверяемая строка.
Возвращаемое значение: Булево – Истина, если переданная строка является уникальным идентификатором.

Функция ЭтоУникальныйИдентификатор(Знач Значение) Экспорт
 Шаблон = "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX"; 
Если СтрДлина(Шаблон) <> СтрДлина(Значение) Тогда  
   Возврат Ложь;
 КонецЕсли; 
Для Позиция = 1 По СтрДлина(Значение) Цикл 
    Если КодСимвола(Шаблон, Позиция) = 88 // X 
      И ((КодСимвола(Значение, Позиция) < 48 Или КодСимвола(Значение, Позиция) > 57) // 0..9   
     И (КодСимвола(Значение, Позиция) < 97 Или КодСимвола(Значение, Позиция) > 102) // a..f       
     И (КодСимвола(Значение, Позиция) < 65 Или КодСимвола(Значение, Позиция ) > 70)) // A..F  
       Или КодСимвола(Шаблон, Позиция) = 45 И КодСимвола(Значение,Позиция) <> 45 Тогда  // -             
Возврат Ложь;
     КонецЕсли;
 КонецЦикла;
 Возврат Истина;
 КонецФункции

См. также

0

Автор публикации

не в сети 2 недели

master1c8

0
Комментарии: 16Публикации: 447Регистрация: 25-12-2016

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.