Выделенные строки коллекции значений

Печать (Ctrl+P)

Работа с коллекциями значений

Часто приходится работать с выделенными строками пользователем в различных элементах формы типа коллекции:

  • Дерево значений
  • Динамический список
  • Список значений
  • Таблица значений

Для работы выделенными строками коллекции используется свойство коллекции ВыделенныеСтроки , которое содержит массив идентификаторов выделенных строк.

Для демонстрации работы с выделенными строками, я создал в управляемой форме внешней обработки 4 вида коллекции ( см. Рис 1 )

Свойства ВыделенныеСтроки используется вместе с методом коллекции формы НайтиПоИдентификатору(<Идентификатор>) , которое получает элемент коллекции по идентификатору или с методом ДанныеСтроки(<Строка>) , который возвращает значение, содержащее данные указанной строки.

Следующий программный кок показывает как использовать свойство
ВыделенныеСтроки в различных видах коллекции

&НаКлиенте
Процедура РаботаСвыделеннымиСтроками()
	   // Коллекция  Дерево Значений
	Для Каждого ВыделеннаяСтрока Из Элементы.ДеревоЗначений.ВыделенныеСтроки Цикл
		 ЭлементДерево = Элементы.ДеревоЗначений.ДанныеСтроки(ВыделеннаяСтрока);
	 КонецЦикла;
	    // Коллекция  Динамический Список
	 Для Каждого ВыделеннаяСтрока Из Элементы.ДинамическийСписок.ВыделенныеСтроки Цикл
		 СтрокаДинамическогоСписка = Элементы.ДинамическийСписок.ДанныеСтроки(ВыделеннаяСтрока);
	 КонецЦикла;
     // Коллекция  Таблица Значений
	 Для Каждого ВыделеннаяСтрока Из Элементы.ТаблицаЗначений.ВыделенныеСтроки Цикл
	 СтрокаТаблицыЗначений = Элементы.ТаблицаЗначений.ДанныеСтроки(ВыделеннаяСтрока);
	 КонецЦикла;
    // Коллекция  Список Значений
	   Для Каждого ВыделеннаяСтрока Из Элементы.ТаблицаЗначений.СписокЗначений.ВыделенныеСтроки Цикл
		 ЭлементСпискаЗначений = СписокЗначений.НайтиПоИдентификатору(ВыделеннаяСтрока);
		 ЭлементСпискаЗначений = Элементы.СписокЗначений.ДанныеСтроки(ВыделеннаяСтрока);
	   КонецЦикла;

	 
КонецПроцедуры
0

Автор публикации

не в сети 2 дня

master1c8

0
Комментарии: 10Публикации: 425Регистрация: 25-12-2016

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.