Выделенные строки коллекции значений

Печать (Ctrl+P)

Работа с коллекциями значений

Часто приходится работать с выделенными строками пользователем в различных элементах формы типа коллекции:

  • Дерево значений
  • Динамический список
  • Список значений
  • Таблица значений

Для работы выделенными строками коллекции используется свойство коллекции ВыделенныеСтроки , которое содержит массив идентификаторов выделенных строк.

Для демонстрации работы с выделенными строками, я создал в управляемой форме внешней обработки 4 вида коллекции ( см. Рис 1 )

Свойства ВыделенныеСтроки используется вместе с методом коллекции формы НайтиПоИдентификатору(<Идентификатор>) , которое получает элемент коллекции по идентификатору или с методом ДанныеСтроки(<Строка>) , который возвращает значение, содержащее данные указанной строки.

Следующий программный кок показывает как использовать свойство
ВыделенныеСтроки в различных видах коллекции

&НаКлиенте
Процедура РаботаСвыделеннымиСтроками()
	   // Коллекция  Дерево Значений
	Для Каждого ВыделеннаяСтрока Из Элементы.ДеревоЗначений.ВыделенныеСтроки Цикл
		 ЭлементДерево = Элементы.ДеревоЗначений.ДанныеСтроки(ВыделеннаяСтрока);
	 КонецЦикла;
	    // Коллекция  Динамический Список
	 Для Каждого ВыделеннаяСтрока Из Элементы.ДинамическийСписок.ВыделенныеСтроки Цикл
		 СтрокаДинамическогоСписка = Элементы.ДинамическийСписок.ДанныеСтроки(ВыделеннаяСтрока);
	 КонецЦикла;
     // Коллекция  Таблица Значений
	 Для Каждого ВыделеннаяСтрока Из Элементы.ТаблицаЗначений.ВыделенныеСтроки Цикл
	 СтрокаТаблицыЗначений = Элементы.ТаблицаЗначений.ДанныеСтроки(ВыделеннаяСтрока);
	 КонецЦикла;
    // Коллекция  Список Значений
	   Для Каждого ВыделеннаяСтрока Из Элементы.ТаблицаЗначений.СписокЗначений.ВыделенныеСтроки Цикл
		 ЭлементСпискаЗначений = СписокЗначений.НайтиПоИдентификатору(ВыделеннаяСтрока);
		 ЭлементСпискаЗначений = Элементы.СписокЗначений.ДанныеСтроки(ВыделеннаяСтрока);
	   КонецЦикла;

	 
КонецПроцедуры
1

Автор публикации

не в сети 7 часов

master1c8

1
Комментарии: 38Публикации: 477Регистрация: 25-12-2016
Previous Article
Next Article

3 Replies to “Выделенные строки коллекции значений”

  1. Алексей

    “Следующий программный кок показывает как использовать свойство”
    Исправьте “коК” на “коД”

    -1
  2. Alx2410

    Хотелось бы понять как для динамического списка реализовать кнопку вниз и кнопку вверх (для тонкого клиента и мобильного клиента). Так чтобы была аналогия нажатий кнопок вниз и вверх как на клавиатуре

    0
    • master1c8

      Возможно я не совсем понял вопрос!!! . У командной панели динамического списка есть стандартные команды. Одни из них – перестановка строк вниз и верх списка. Однако, НЕ просто реализовать программным перестановку строк динамического списка потому, что у динамического списка недоступен обход строк. Для обхода строк нужно получить таблицу значений из динамического список , затем переставлять строки как нужно в таблице значений , а затем обратно получить динамический список

      0

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте, как обрабатываются ваши данные комментариев.