Блокировка данных для редактирования. Пример

Печать (Ctrl+P)

Управляемые формы. Платформа 1С 8.3

Объект конфигурации Нумераторы в дереве документов обеспечивает порядок нумерации стандартного реквизита документов – Номер .

Для обеспечения порядка нумерации других реквизитов документа типа число или строка приходится создавать собственные нумераторы ( или счетчики) в виде регистра сведений.

Например, в одной конфигурации создан вид документа
“Страховой полис”, который кроме стандартного реквизита номер , содержит еще реквизит Номер полиса , порядок  нумерации которого от контрагента ( исполнителя) документа ( страховой компании).

Для обеспечения уникальности нумерации реквизита Номер полиса в разрезе контрагента, я создал периодический в приделах года, регистр сведения Нумератор Полиса . Этот регистр содержал одно измерение – Контрагент и один ресурс – Номер

Однако, были случай, когда при интенсивном создании документа полиса на основании документа Заказ покупателя без блокировки нумератора создавались дублированные номера полиса. Причина была в том, что новый номер не успевал записаться в регистре сведения Нумератор полиса до того, как поступал новый запрос на получение очередного номера полиса.

Причина кажется не вероятно !.Но факт есть факт. Особенно при сильно загрузке сервера нумератор раздавал один и тот же номер разным полисам потому, что он не успевал его записывать.

Проблема была решена после блокировки нумератора (счетчика) перед чтением с помощью метода глобального контекста:

 ЗаблокироватьДанныеДляРедактирования(<Ключ>, <ВерсияДанных>,  <ИдентификаторФормы>) 

и разблокирования нумератора (счетчика) после записи очередного номера полиса с помощью метода глобального контекста:

РазблокироватьДанныеДляРедактирования(<Ключ>, <ИдентификаторФормы>) 

Другие примеры блокировки данных для редактирования из встроенного языка можно посмотреть по ссылке здесь .

В этой статье я рассматриваю следующий практический пример:

Перед записью документа Полис требуется заблокировать Нумератор полиса , если это удалось, модифицировать документ Полис – присвоить очередной номер полиса . В противном случае – проинформировать пользователя об отказе в выполнении операции записи полиса такого вида: 

Не удалось заблокировать нумератор полиса. Документ полис не может быть записан . Повторите попытку!

Решение этого примера выполняется в теле обработчика события ПередЗаписьюНаСервере.

Данное событие вызывается перед записью полиса на сервере и выполняется вне транзакции. Можно отменить запись полиса если в теле процедуры-обработчика установить отказ = истина.

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если Не ЗначениеЗаполнено(ТекущийОбъект.НомерПолиса) Тогда	
НомерПолиса = ПолучитьНомерПолиса (ТекущийОбъект.Контрагент); 
	Если НомерПолиса = 0 Тогда 
	Отказ = Истина;
	Сообщить(" Не удалось записать полис!. Повторите попытку");
Иначе
	ТекущийОбъект.НомерПолиса = НомерПолиса;
КонецЕсли;
КонецЕсли; 
КонецПроцедуры

Обратите внимание, что вызов функции
ПолучитьНомерПолиса происходит если номер полиса не заполнен. Кроме того, запись полиса отменяется если она возвращает ноль при ее вызове .

Весь программный код можно было бы поместить в модуле объекта в обработчике события ПередЗаписью , а не в модуле управляемой формы полиса.

Программный код пользовательской функции возвращающей номер полиса и осуществляющей чтение и запись с блокировкой нумератора полиса показан в следующем фрагменте:

&НаСервере
Функция ПолучитьНомерПолиса (Контрагент)
	Номер=0; 
Отбор = Новый Структура; 
	Отбор.Вставить("Контрагент", Контрагент); 
	КлючЗаписи = РегистрыСведений._НумераторПолиса.СоздатьКлючЗаписи(Отбор); 
Попытка
	ЗаблокироватьДанныеДляРедактирования(КлючЗаписи);  
	Запрос = Новый Запрос; 
	Запрос.Текст = "ВЫБРАТЬ 
	|_НумераторПолисаСрезПоследних.Номер КАК Номер 
	|ИЗ 
	|РегистрСведений._НумераторПолиса.СрезПоследних(, Контрагент = &Контрагент) КАК _НумераторПолисаСрезПоследних ; 
	Запрос.УстановитьПараметр("Контрагент", Контрагент); 
	Выборка = Запрос.Выполнить().Выбрать(); 
	Если Выборка.Следующий() Тогда
		Номер = Выборка.Номер;
	КонецЕсли; 
		Номер = Номер+1;
		запись = РегистрыСведений._НумераторПолиса.СоздатьМенеджерЗаписи();
		запись.Контрагент = Контрагент;
		запись.Период = ТекущаяДата(); 
		запись.Номер =Номер; 
		Запись.Записать(); 
		РазблокироватьДанныеДляРедактирования(КлючЗаписи);
	Исключение
Сообщить( «Не удалось заблокировать нумератор. Он уже заблокирован"; 
		Возврат 0;
	КонецПопытки; 
	Возврат Номер;
КонецФункции

Обратите внимание, что блокировка записи происходит до выполнения запроса о чтении номера. Если запись заблокирована вызывается исключение и функция возвращает 0.

Часто блокирование и разблокирование происходит внутри транзакции. Причем, транзакция начинается перед блокированием данных и зафикируется после разблокирования . Вот пример из библиотеки стандартных подсистем при старте отложенного бизнес-процесса

	Процедура СтартоватьОтложенныйПроцесс(БизнесПроцесс) Экспорт
	
	НачатьТранзакцию();
	
	Попытка
		
		ЗаблокироватьДанныеДляРедактирования(БизнесПроцесс);
		
		БизнесПроцессОбъект = БизнесПроцесс.ПолучитьОбъект();
		// Стартуем бизнес процесс и регистрируем этот старт в регистре.
		БизнесПроцессОбъект.Старт();
		РегистрыСведений.ПроцессыДляЗапуска.ЗарегистрироватьСтартПроцесса(БизнесПроцесс);
		
		РазблокироватьДанныеДляРедактирования(БизнесПроцесс);
		
		ЗафиксироватьТранзакцию();
		
	Исключение
		
		ОтменитьТранзакцию();
		
		ОписаниеОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке());
		
		ТекстОшибки = НСтр("ru = 'Во время отложенного старта этого процесса произошла ошибка:
			|%1
			|Попробуйте запустить процесс вручную, а не отложенно.'");
			
		Описание = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
			ТекстОшибки,
			ОписаниеОшибки);
		
		РегистрыСведений.ПроцессыДляЗапуска.ЗарегистрироватьОтменуСтарта(БизнесПроцесс, Описание);
			
	КонецПопытки;
	
КонецПроцедуры

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.