Обработка Выбора в поле ввода формы

Печать (Ctrl+P)

1С:Предприятие 8.3.14. Документация
Глава 7. Формы

Для демонстрации работы параметров формы рассмотрим реализацию выбора элемента в поле ввода. Сутью примера будет реализация механизма выбора элемента из списка на встроенном языке.

К моменту начала работы с примером нужно иметь конфигурацию, обладающую следующими свойствами:

  • имеется справочник Товары с иерархией групп и элементов;
  • имеется справочник Аналоги с реквизитом ВыбранныйТовар типа СправочникСсылка.Товары;
  • оба справочника имеют формы элементов.

Теперь реализуем в этой конфигурации все механизмы, которые использует платформа для выбора элемента из списка, на встроенном языке. При этом мы увидим:

  • как происходит использование стандартных параметров формы;
  • каким образом их использует сама система;
  • как их может использовать разработчик.

Добавим дополнительный параметр, который будет управлять закрытием формы выбора после выбора элемента. Назовем этот параметр ЗакрыватьПослеВыбора (тип Булево). Добавим его в качестве параметра формы ФормаВыбора справочника Товары.

Для того чтобы открыть форму выбора элемента, необходимо в форме элемента справочника Аналоги создать обработчик события НачалоВыбора у элемента формы ВыбранныйТовар.

&НаКлиенте
Процедура ВыбранныйТоварНачалоВыбора(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
СтруктураПараметров = Новый Структура; СтруктураПараметров.Вставить("РежимВыбора", Истина);
СтруктураПараметров.Вставить("ВыборГруппИЭлементов", ИспользованиеГруппИЭлементов.Элементы);
СтруктураПараметров.Вставить("РазрешитьВыборКорня", Ложь);
СтруктураПараметров.Вставить("ТекущаяСтрока", Объект.ВыбранныйТовар);
СтруктураПараметров.Вставить("ЗакрыватьПослеВыбора", Ложь);
ОткрытьФорму("Справочник.Товары.ФормаВыбора", СтруктураПараметров, Элементы.ВыбранныйТовар);
КонецПроцедуры

Следует отдельно остановиться на третьем параметре метода ОткрытьФорму(). Этот параметр определяет, кто будет владельцем формы выбора и кому будет приходить оповещение о сделанном выборе. В данном случае мы указали владельцем формы выбора сам элемент формы, но также мы можем указать этим параметром и саму форму. В этом случае будет необходимо реализовывать обработчик ОбработкаВыбора модуля формы и в нем решать, в какой реквизит формы помещать выбранные данные.

ПРИМЕЧАНИЕ. Если мы не будем реализовывать обработчик события НачалоВыбора, то его действия выполнит сама система. Это справедливо и для всех дальнейших обработчиков, которые использованы в примере.

Теперь необходимо обработать переданные параметры в форме выбора. Сделаем это в обработчике ПриСозданииНаСервере() модуля формы выбора.

 &НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
Элементы.Список.ВыборГруппИЭлементов = Параметры.ВыборГруппИЭлементов;
Элементы.Список.РазрешитьВыборКорня = Параметры.РазрешитьВыборКорня;
Элементы.Список.ТекущаяСтрока = Параметры.ТекущаяСтрока;
ЗакрыватьПриВыборе = Параметры.ЗакрыватьПослеВыбора;
КонецПроцедуры

Для того чтобы проверить работоспособность установленных нами параметров формы, установим, с помощью конфигуратора, у таблицы формы выбора Список свойство ВыборГруппИЭлементов в значение Группы (без применения параметра не будет доступен выбор элементов справочника).

ПРИМЕЧАНИЕ. Если у таблицы Список, отображающей список товаров, свойство РежимВыбора не будет установлено в значение Истина, то выбор товаров будет недоступен.

Теперь нам необходимо обработать выбор желаемого элемента в форме выбора. Для этого нужно определить обработчик события ВыборЗначения таблицы формы.

 &НаКлиенте 
Процедура СписокВыборЗначения(Элемент, СтандартнаяОбработка, Значение)
 СтандартнаяОбработка = Ложь; 
  ОповеститьОВыборе(Значение);
 КонецПроцедуры 

Нам осталось реализовать обработку выбора элемента в самом поле ввода. Для этого необходимо обработать событие ОбработкаВыбора нашего поля ввода ВыбранныйТовар.

Мы самостоятельно реализовали системный механизм выбора значения в поле ввода на форме.

&НаКлиенте
 Процедура СписокВыборЗначения(Элемент, СтандартнаяОбработка, Значение)
  СтандартнаяОбработка = Ложь;
  ОповеститьОВыборе(Значение); 
 КонецПроцедуры 

ВНИМАНИЕ! Данный пример не является законченным. Его единственным назначением является демонстрация механизмов работы с параметрами формы.

Если при создании параметров (обработчик ВыбранныйТоварНачалоВыбора()) заменить строку:

  ПараметрыВыбора.Вставить("ЗакрыватьПослеВыбора", Истина); 

на строку:

  ПараметрыВыбора.Вставить("ЗакрыватьПослеВыбора", Ложь); 

то форма выбора перестанет закрываться после того, как будет осуществлен выбор. Это можно использовать, например, для реализации формы подбора (выбор нескольких товаров без закрытия формы выбора).

Previous Article
Next Article

Добавить комментарий

Ваш адрес email не будет опубликован.

Этот сайт использует Akismet для борьбы со спамом. Узнайте, как обрабатываются ваши данные комментариев.